Description:

Compares this Point3d with another Point3d . Component evaluation priority is first X, then Y, then Z.

Syntax:
public int CompareTo(
Point3d other
)
Parameters:
  • other
  • Type: Point3d
  • The other Point3d to use in comparison.
Returns:
Type: int
0: if this is identical to other -1: if this.X < other.X -1: if this.X == other.X and this.Y < other.Y -1: if this.X == other.X and this.Y == other.Y and this.Z < other.Z +1: otherwise.
Available since:
5.0

CompareTo method

Class:  Rhino.Geometry.Point3d

Nothing found