Description:

Initializes a new point by defining the X, Y and Z coordinates.

Syntax:
public Point3d(
double x,
double y,
double z
)
Parameters:
  • x
  • Type: double
  • The value of the X (first) coordinate.
  • y
  • Type: double
  • The value of the Y (second) coordinate.
  • z
  • Type: double
  • The value of the Z (third) coordinate.
Available since:
5.0

Description:

Initializes a new point by copying coordinates from another point.

Syntax:
public Point3d(
Point3d point
)
Parameters:
Available since:
5.0

Description:

Initializes a new point by copying coordinates from a single-precision point.

Syntax:
public Point3d(
Point3f point
)
Parameters:
Available since:
5.0

Description:

Initializes a new point by copying coordinates from a four-dimensional point. The first three coordinates are divided by the last one. If the W (fourth) dimension of the input point is zero, then it will be just discarded.

Syntax:
public Point3d(
Point4d point
)
Parameters:
Available since:
5.0

Description:

Initializes a new point by copying coordinates from the components of a vector.

Syntax:
public Point3d(
Vector3d vector
)
Parameters:
Available since:
5.0

Point3d constructor

Class:  Rhino.Geometry.Point3d

Nothing found