Description:

Gets a NURBS surface representation of this surface. Default tolerance of 0.0 is used.

Syntax:
public NurbsSurface ToNurbsSurface()
Returns:
NurbsSurface on success, None on failure.
Available since:
5.0

Description:

Gets a NURBS surface representation of this surface.

Syntax:
public NurbsSurface ToNurbsSurface(
double tolerance,
out int accuracy
)
Parameters:
  • tolerance
  • Type: double
  • tolerance to use when creating NURBS representation.
  • accuracy
  • Type: int
  • 0 = unable to create NURBS representation with desired accuracy. 1 = success - returned NURBS parameterization matches the surface's to the desired accuracy. 2 = success - returned NURBS point locus matches the surface's to the desired accuracy and the domain of the NURBS surface is correct. However, this surface's parameterization and the NURBS surface parameterization may not match to the desired accuracy. This situation happens when getting NURBS representations of surfaces that have a transcendental parameterization like spheres, cylinders, and cones.
Returns:
NurbsSurface on success, None on failure.
Available since:
5.0

/
/
/
ToNurbsSurface

ToNurbsSurface method

Class:  Rhino.Geometry.Surface

Nothing found