Description:

Tests a surface with the assumption that it might be a right circular cylinder and returns this geometry.

Syntax:
public bool TryGetFiniteCylinder(
out Cylinder cylinder,
double tolerance
)
Parameters:
  • cylinder
  • Type: Cylinder
  • On success, the cylinder parameters are filled in.
  • tolerance
  • Type: double
  • tolerance to use when checking.
Returns:
Type: bool
True if the surface is a portion of a cylinder.
Remarks:
If successful, a finite cylinder is returned.
Available since:
6.0

/
/
/
TryGetFiniteCylinder

TryGetFiniteCylinder method

Class:  Rhino.Geometry.Surface

Nothing found