Description:

Adds a command line list option.

Syntax:
public int AddOptionList(
LocalizeStringPair optionName,
IEnumerable<LocalizeStringPair> listValues,
int listCurrentIndex
)
Parameters:
  • optionName
  • Type: LocalizeStringPair
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes)
  • listValues
  • Type: IEnumerable<LocalizeStringPair>
  • The string values.
  • listCurrentIndex
  • Type: int
  • Zero based index of current option.
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Description:

Adds a command line list option.

Syntax:
public int AddOptionList(
string englishOptionName,
IEnumerable<string> listValues,
int listCurrentIndex
)
Parameters:
  • englishOptionName
  • Type: string
  • Must only consist of letters and numbers (no characters list periods, spaces, or dashes)
  • listValues
  • Type: IEnumerable<string>
  • The string values.
  • listCurrentIndex
  • Type: int
  • Zero based index of current option.
Returns:
Type: int
option index value (>0) or 0 if option cannot be added.
Available since:
5.0

Nothing found