Description:

Sets a number as default value that will be returned if the user presses ENTER key during the get.

Syntax:
public void SetDefaultInteger(
int defaultValue
)
Parameters:
  • defaultValue
  • Type: int
  • value for default number.
Returns:
Type: void
Remarks:
Calling SetDefaultInteger will automatically handle setting the command prompt default and reacting to the user pressing ENTER. If the user presses ENTER to accept the default integer, GetResult.Number is returned and CRhinoGet.GotDefault() will return true. Calling SetDefaultNumber will clear any previous calls to SetDefaultString or SetDefaultPoint.
Available since:
5.0

SetDefaultInteger method

Class:  Rhino.Input.Custom.GetBaseClass

Nothing found