Description:

Sets a string as default value that will be returned if the user presses ENTER key during the get.

Syntax:
public void SetDefaultString(
string defaultValue
)
Parameters:
  • defaultValue
  • Type: string
  • value for default string.
Returns:
Type: void
Remarks:
Calling SetDefaultString will automatically handle setting the command prompt default and reacting to the user pressing ENTER. If the user presses ENTER to accept the default string, GetResult.String is returned and RhinoGet.GotDefault() will return true. Calling SetDefaultString will clear any previous calls to SetDefaultNumber or SetDefaultPoint.
Available since:
5.0

SetDefaultString method

Class:  Rhino.Input.Custom.GetBaseClass

Nothing found