menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Awaits a particular task to finish.
Syntax:
public
Result
Wait(
Task
task
,
RhinoDoc
doc
)
Parameters:
task
Type:
System.Threading.Tasks.Task
The task.
doc
Type:
RhinoDoc
A document to set progress reporting.
Returns:
Type:
Result
A result enumeration.
Available since:
7.0
Description:
Awaits a particular task to finish.
Syntax:
public
Result
Wait(
Task<TResult>
task
,
RhinoDoc
doc
)
Parameters:
task
Type:
Task<TResult>
The task.
doc
Type:
RhinoDoc
A document to set progress reporting.
Returns:
Type:
Result
A result enumeration.
Available since:
6.0
home
/
Rhino.Input.Custom
/
GetCancel
/
Wait
Wait method
Class:
Rhino.Input.Custom.GetCancel
Nothing found