Description:

If enabled, the picked point is constrained to be on the active construction plane. If the base point is set, then the point is constrained to be on the plane that contains the base point and is parallel to the active construction plane. By default this constraint is enabled.

Syntax:
public bool ConstrainToConstructionPlane(
bool throughBasePoint
)
Parameters:
  • throughBasePoint
  • Type: bool
  • True if the base point should be used as compulsory level reference.
Returns:
Type: bool
If True and the base point is set, then the point is constrained to be on the plane parallel to the construction plane that passes through the base point, even when planar mode is off. If throughBasePoint is false, then the base point shift only happens if planar mode is on.
Available since:
5.0

/
/
/
ConstrainToConstructionPlane

ConstrainToConstructionPlane method

Class:  Rhino.Input.Custom.GetPoint

Nothing found