Description:

Control the availability of the built-in linear, planar, curve, and surface constraint options like "Along", "AlongPerp", "AlongTan", "AlongParallel", "Between", "OnCrv", "OnSrf", ".x", ".y", ".z", ".xy", etc.

Syntax:
public void PermitConstraintOptions(
bool permit
)
Parameters:
  • permit
  • Type: bool
  • if true, then the built-in constraint options are automatically available in GetPoint.
Returns:
Type: void
Remarks:
By default, these built-in constraint options are available unless an explicit constraint is added by calling one of the GetPoint::Constrain functions. Calling GetPoint::ClearConstraints automatically enables the built-in constraint options. The built-in constraint options are never visible on the command line and the user must type the complete option name to activate these options.
Available since:
5.0

/
/
/
PermitConstraintOptions

PermitConstraintOptions method

Class:  Rhino.Input.Custom.GetPoint

Nothing found