Description:

Control the availability of the built-in "From" option. By default, the "From" option is enabled.

Syntax:
public void PermitFromOption(
bool permit
)
Parameters:
  • permit
  • Type: bool
  • if true, then the "From" option is automatically available in GetPoint.
Returns:
Type: void
Remarks:
The GetPoint "From" option is never visible on the command line and the user must type the complete option name to activate the "From" option. When the GetPoint "From" snap is enabled, the user set/change the base point during GetPoint by typing "From" and picking a point. A related option is the built-in distance from base point constraint that is can be set before GetPoint is called by passing a value to GetPoint::ConstrainDistanceFromBasePoint or during GetPoint by entering a number.
Available since:
5.0

PermitFromOption method

Class:  Rhino.Input.Custom.GetPoint

Nothing found