Description:

Gets a 3d box with prompts for counts in X, Y and Z directions.

Syntax:
public static Result GetBoxWithCounts(
int xMin,
ref int xCount,
int yMin,
ref int yCount,
int zMin,
ref int zCount,
out Point3d[] corners
)
Parameters:
  • xMin
  • Type: int
  • Minimum value allowed for count in the x direction.
  • xCount
  • Type: int
  • Count in the x direction.
  • yMin
  • Type: int
  • Minimum value allowed for count in the y direction.
  • yCount
  • Type: int
  • Count in the y direction.
  • zMin
  • Type: int
  • Minimum value allowed for count in the z direction.
  • zCount
  • Type: int
  • Count in the z direction.
  • corners
  • Type: Point3d[]
  • corners of the bottom rectangle in counter-clockwise order, followed by top rectangle.
Returns:
Type: Result
Commands.Result.Success if successful.
Available since:
6.0

/
/
/
GetBoxWithCounts

GetBoxWithCounts method

Class:  Rhino.Input.RhinoGet

Nothing found