Description:

Easy to use object getter for getting multiple objects.

Syntax:
public static Result GetMultipleObjects(
string prompt,
bool acceptNothing,
GetObjectGeometryFilter filter,
out ObjRef[] rhObjects
)
Parameters:
  • prompt
  • Type: string
  • command prompt.
  • acceptNothing
  • Type: bool
  • if true, the user can press enter.
  • rhObjects
  • Type: ObjRef[]
  • result of the get. may be null.
Returns:
Type: Result
Commands.Result.Success - got object Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel object getting.
Remarks:
If you need options or more advanced user interface, then use GetObject class.
Available since:
5.0

Description:

Easy to use object getter for getting multiple objects.

Syntax:
public static Result GetMultipleObjects(
string prompt,
bool acceptNothing,
ObjectType filter,
out ObjRef[] rhObjects
)
Parameters:
  • prompt
  • Type: string
  • command prompt.
  • acceptNothing
  • Type: bool
  • if true, the user can press enter.
  • filter
  • Type: ObjectType
  • geometry filter to use when getting objects.
  • rhObjects
  • Type: ObjRef[]
  • result of the get. may be null.
Returns:
Type: Result
Commands.Result.Success - got object Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel object getting.
Remarks:
If you need options or more advanced user interface, then use GetObject class.
Available since:
5.0

/
/
/
GetMultipleObjects

GetMultipleObjects method

Class:  Rhino.Input.RhinoGet

Nothing found