Description:
Easy to use object getter.
Syntax:
public static Result GetOneObject(
string prompt,
bool acceptNothing,
GetObjectGeometryFilter filter,
out ObjRef objref
)
string prompt,
bool acceptNothing,
GetObjectGeometryFilter filter,
out ObjRef objref
)
Parameters:
- prompt
- Type: string
- command prompt.
- acceptNothing
- Type: bool
- if true, the user can press enter.
- filter
- Type: GetObjectGeometryFilter
- geometry filter to use when getting objects.
- objref
- Type: ObjRef
- result of the get. may be null.
Returns:
Type: Result
Commands.Result.Success - got object Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel object getting.
Remarks:
If you need options or more advanced user interface, then use GetObject class.
Available since:
5.0
Description:
Easy to use object getter.
Syntax:
public static Result GetOneObject(
string prompt,
bool acceptNothing,
ObjectType filter,
out ObjRef rhObject
)
string prompt,
bool acceptNothing,
ObjectType filter,
out ObjRef rhObject
)
Parameters:
- prompt
- Type: string
- command prompt.
- acceptNothing
- Type: bool
- if true, the user can press enter.
- filter
- Type: ObjectType
- geometry filter to use when getting objects.
- rhObject
- Type: ObjRef
- result of the get. may be null.
Returns:
Type: Result
Commands.Result.Success - got object Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel object getting.
Remarks:
If you need options or more advanced user interface, then use GetObject class.
Available since:
5.0