Description:

Easy to use string getter.

Syntax:
public static Result GetString(
string prompt,
bool acceptNothing,
ref string outputString
)
Parameters:
  • prompt
  • Type: string
  • command prompt.
  • acceptNothing
  • Type: bool
  • if true, the user can press enter.
  • outputString
  • Type: string
  • default string set to this value and string value returned here.
Returns:
Type: Result
Commands.Result.Success - got string Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel string getting.
Remarks:
If you need options or more advanced user interface, then use GetString class.
Available since:
5.0

GetString method

Class:  Rhino.Input.RhinoGet

Nothing found