Description:

Returns the names of all installed Rhino plug-ins.

Syntax:
public static string GetInstalledPlugInNames()
Returns:
Type: string
The names if successful.
Available since:
5.0

Description:

Gets a list of installed plug-in names. The list can be restricted by some filters.

Syntax:
public static string GetInstalledPlugInNames(
PlugInType typeFilter,
bool loaded,
bool unloaded,
bool localizedPlugInName
)
Parameters:
  • typeFilter
  • Type: PlugInType
  • The enumeration flags that determine which types of plug-ins are included.
  • loaded
  • Type: bool
  • True if loaded plug-ins are returned.
  • unloaded
  • Type: bool
  • True if unloaded plug-ins are returned.
  • localizedPlugInName
  • Type: bool
  • If True localized plug-in names are returned otherwise; English names are returned.
Returns:
Type: string
An array of installed plug-in names. This can be empty, but not null.
Available since:
7.5

Description:

Gets a list of installed plug-in names. The list can be restricted by some filters.

Syntax:
public static string GetInstalledPlugInNames(
PlugInType typeFilter,
bool loaded,
bool unloaded
)
Parameters:
  • typeFilter
  • Type: PlugInType
  • The enumeration flags that determine which types of plug-ins are included.
  • loaded
  • Type: bool
  • True if loaded plug-ins are returned.
  • unloaded
  • Type: bool
  • True if unloaded plug-ins are returned.
Returns:
Type: string
An array of installed plug-in names. This can be empty, but not null.
Available since:
5.0

/
/
/
GetInstalledPlugInNames

GetInstalledPlugInNames method

Class:  Rhino.PlugIns.PlugIn

Nothing found