Description:
Called whenever a Rhino document is being loaded and plug-in user data was encountered written by a plug-in with this plug-in's GUID.
Syntax:
protected virtual void ReadDocument(
RhinoDoc doc,
BinaryArchiveReader archive,
FileReadOptions options
)
RhinoDoc doc,
BinaryArchiveReader archive,
FileReadOptions options
)
protected
virtual
Parameters:
- doc
- Type: RhinoDoc
- A Rhino document that is being loaded.
- archive
- Type: FileIO.BinaryArchiveReader
- OpenNURBS file archive object Rhino is using to read this file. Use BinaryArchiveReader.Read*() functions to read plug-in data. If any BinaryArchive.Read*() functions throws an exception then archive.ReadErrorOccurve will be True and you should immediately return.
- options
- Type: FileIO.FileReadOptions
- Describes what is being written.
Returns:
Type: void