Description:

Creates the preview bitmap that will appear in the content editor's thumbnail display when previewing materials and environments. If this function is not overridden or the PreviewImage is not set on the arguments, then the internal OpenGL renderer will generate a simulation of the content. This function is called with four different preview quality settings. The first quality level of RealtimeQuick is called on the main thread and needs to be drawn as fast as possible. This function is called with the other three quality settings on a separate thread and are meant for generating progressively refined preview.

Syntax:
protected virtual void CreatePreview(
CreatePreviewEventArgs args
)
protected
virtual
Parameters:
Returns:
Type: void

CreatePreview method

Class:  Rhino.PlugIns.RenderPlugIn

Nothing found