Description:

Override this function to handle showing a modal dialog with your plug-in's custom decal properties. You will be passed the current properties for the object being edited. The defaults will be set in InitializeDecalProperties.

Syntax:
protected virtual bool ShowDecalProperties(
ref List<NamedValue> properties
)
protected
virtual
Parameters:
  • properties
  • Type: List<NamedValue>
  • A list of named values that will be stored on the object the input values are the current ones, you should modify the values after the dialog closes.
Returns:
Type: bool
True if the user pressed "OK", otherwise false.

/
/
/
ShowDecalProperties

ShowDecalProperties method

Class:  Rhino.PlugIns.RenderPlugIn

Nothing found