RealtimeDisplayMode class
Base class for implementing real-time display modes in .NET. Pay special attention that in StartRenderer the RenderWindow.SetSize() function is called if the implementation relies on the RenderWindow to do the drawing to the viewport. If i.e. OpenGL is used to draw render results to the viewport then SetSize() doesn't have to be called, nor should the implementation then access channels on the RenderWindow, as those then don't exist. For OpenGL-based drawing the RenderWindow is used as a container for ViewInfo management, nothing else.
Derived Classes:
Namespace: Rhino.Render
RealtimeDisplayMode: references
keyboard_arrow_down
Constructors (1)
keyboard_arrow_down
Properties (5)
keyboard_arrow_down
Methods (40)