Description:

Extra requirements are a way of specifying extra functionality on parameters in the automatic UI. See IAutoUIExtraRequirements.h in the C++ RDK SDK for string definitions for the parameter names.

Syntax:
public object GetExtraRequirementParameter(
string contentParameterName,
string extraRequirementParameter
)
Parameters:
  • contentParameterName
  • Type: string
  • The parameter or field internal name to which this query applies.
  • extraRequirementParameter
  • Type: string
  • The extra requirement parameter, as listed in IAutoUIExtraRequirements.h in the C++ RDK SDK.
Returns:
Type: object
The value of the requested extra requirement parameter or None if the parameter does not exist. Current supported return values are (int, bool, float, double, string, Guid, Color, Vector3d, Point3d, DateTime).
Available since:
7.9

/
/
/
GetExtraRequirementParameter

GetExtraRequirementParameter method

Class:  Rhino.Render.RenderContent

Nothing found