Description:

Set another content as a child of this content. This content may or may not be attached to a document. If this content already has a child with the specified child slot name, that child will be deleted. If this content is not attached to a document, the child will be added without sending any events. If this content is attached to a document, the necessary events will be sent to update the UI. Note: Do not call this method to add children in your constructor. If you want to add default children, you should override Initialize() and add them there.

Syntax:
public bool SetChild(
RenderContent renderContent,
String childSlotName,
ChangeContexts changeContexts
)
deprecated in 6.0
Parameters:
  • renderContent
  • Type: RenderContent
  • Child content to add to this content. If pChild is NULL, the function will fail. If pChild is already attached to a document, the function will fail. If pChild is already a child of this or another content, the function will fail.
  • childSlotName
  • Type: System.String
  • The name that will be assigned to this child slot. The child slot name cannot be an empty string. If it is, the function will fail.
Returns:
Type: bool
Returns True if the content was added or the child slot with this name was modified otherwise; returns false.
Available since:
5.10

Description:

Set another content as a child of this content. This content may or may not be attached to a document. If this content already has a child with the specified child slot name, that child will be deleted. If this content is not attached to a document, the child will be added without sending any events. If this content is attached to a document, the necessary events will be sent to update the UI. Note: Do not call this method to add children in your constructor. If you want to add default children, you should override Initialize() and add them there.

Syntax:
public bool SetChild(
RenderContent renderContent,
String childSlotName
)
Parameters:
  • renderContent
  • Type: RenderContent
  • Child content to add to this content. If renderContent is null, the function will fail. If renderContent is already attached to a document, the function will fail. If renderContent is already a child of this or another content, the function will fail.
  • childSlotName
  • Type: System.String
  • The name that will be assigned to this child slot. The child slot name cannot be an empty string. If it is, the function will fail.
Returns:
Type: bool
Returns True if the content was added or the child slot with this name was modified, otherwise returns false.
Available since:
6.0

Nothing found