Description:
Extra requirements are a way of specifying extra functionality on parameters in the automatic UI. See IAutoUIExtraRequirements.h in the C++ RDK SDK for string definitions for the parameter names.
Syntax:
public bool SetExtraRequirementParameter(
string contentParameterName,
string extraRequirementParameter,
object value,
ExtraRequirementsSetContexts sc
)
string contentParameterName,
string extraRequirementParameter,
object value,
ExtraRequirementsSetContexts sc
)
Parameters:
- contentParameterName
- Type: string
- The parameter or field internal name to which this query applies.
- extraRequirementParameter
- Type: string
- The extra requirement parameter, as listed in IAutoUIExtraRequirements.h in the C++ RDK SDK.
- value
- Type: object
- The value to set this extra requirement parameter. You will typically use System.Convert to convert the value to the type you need.
- sc
- Type: ExtraRequirementsSetContexts
- The context of this operation.
Returns:
Type: bool
True if successful, else false.
Available since:
7.9