Description:

Protected constructor to be called from derived class

Syntax:
protected RenderContentSerializer(
string fileExtension,
RenderContentKind contentKind,
bool canRead,
bool canWrite
)
protected
Parameters:
  • fileExtension
  • Type: string
  • File extension associated with this serialize object
  • contentKind
  • Type: RenderContentKind
  • Kind of content created when importing or exporting this file type.
  • canRead
  • Type: bool
  • If True then the file type can be imported and will be included in the file open box when importing the specified render content kind.
  • canWrite
  • Type: bool
  • If True then the file type can be exported and will be included in the file save box when exporting the specified render content kind.

/
/
/
RenderContentSerializer

RenderContentSerializer constructor

Class:  Rhino.Render.RenderContentSerializer

Nothing found