Description:

Shows the content chooser to allow the user to select a new or existing content, or multiple contents.

Syntax:
public static ShowContentChooserResults ShowContentChooser(
RhinoDoc doc,
Guid defaultType,
Guid defaultInstanceId,
RenderContentKind kinds,
ContentChooserFlags flags,
string presetCategory,
IEnumerable<string> categories,
IEnumerable<Guid> types,
out Guid[] instanceIdsOut
)
Parameters:
  • defaultType
  • Type: System.Guid
  • The content type that will be initially selected in the 'New' tab.
  • defaultInstanceId
  • Type: System.Guid
  • The content instance that will be initially selected in the 'Existing' tab.
  • kinds
  • Type: RenderContentKind
  • Semicolon-delimited string specifying which content kinds will be displayed.
  • presetCategory
  • Type: string
  • Specifies the category to preset in the drop-down list on the 'New' tab. If this string is empty, the preset category will be 'All'.
  • categories
  • Type: IEnumerable<string>
  • Specifies the categories to display. Render contents that do not belong to one of these categories will not be listed. If this array is empty, all render contents from all categories will be listed.
  • types
  • Type: IEnumerable<Guid>
  • Specifies content types to display. Contents that are not one of these types will not be listed. If this array is empty, all content types will be listed.
  • instanceIdsOut
  • Type: System.Guid[]
  • Array of UUID(s) of the chosen item(s). Depending on eRhRdkSccResult, this can accept type id(s) of content type(s) or instance id(s) of existing content(s).
Returns:
The result of displaying the chooser.
Available since:
7.9

Description:

Shows the content chooser to allow the user to select a new or existing content, or multiple contents.

Syntax:
public static ShowContentChooserResults ShowContentChooser(
RhinoDoc doc,
Guid defaultType,
Guid defaultInstanceId,
RenderContentKind kinds,
ShowContentChooserFlags flags,
string presetCategory,
IEnumerable<string> categories,
IEnumerable<Guid> types,
out Guid[] instanceIdsOut
)
deprecated in 7.9
Parameters:
  • defaultType
  • Type: System.Guid
  • The content type that will be initially selected in the 'New' tab.
  • defaultInstanceId
  • Type: System.Guid
  • The content instance that will be initially selected in the 'Existing' tab.
  • kinds
  • Type: RenderContentKind
  • Semicolon-delimited string specifying which content kinds will be displayed.
  • flags
  • Type: ShowContentChooserFlags
  • Flags controlling the chooser (tabs to hide, type of selection).
  • presetCategory
  • Type: string
  • Specifies the category to preset in the drop-down list on the 'New' tab. If this string is empty, the preset category will be 'All'.
  • categories
  • Type: IEnumerable<string>
  • Specifies the categories to display. Render contents that do not belong to one of these categories will not be listed. If this array is empty, all render contents from all categories will be listed.
  • types
  • Type: IEnumerable<Guid>
  • Specifies content types to display. Contents that are not one of these types will not be listed. If this array is empty, all content types will be listed.
  • instanceIdsOut
  • Type: System.Guid[]
  • Array of UUID(s) of the chosen item(s). Depending on eRhRdkSccResult, this can accept type id(s) of content type(s) or instance id(s) of existing content(s).
Returns:
The result of displaying the chooser.
Available since:
7.6

Description:

Shows the content chooser to allow the user to select a new or existing content.

Syntax:
public static ShowContentChooserResults ShowContentChooser(
Guid defaultType,
Guid defaultInstanceId,
RenderContentKind kinds,
ref Guid instanceIdOut,
ShowContentChooserFlags flags,
RhinoDoc doc
)
deprecated in 7.9
Parameters:
  • defaultType
  • Type: System.Guid
  • The content type that will be initially selected in the 'New' tab.
  • defaultInstanceId
  • Type: System.Guid
  • The content instance that will be initially selected in the 'Existing' tab.
  • kinds
  • Type: RenderContentKind
  • Semicolon-delimited string specifying which content kinds will be displayed.
  • instanceIdOut
  • Type: System.Guid
  • The UUID of the chosen item. Depending on eRhRdkSccResult, this can be the type id of a content type or the instance id of an existing content.
  • flags
  • Type: ShowContentChooserFlags
  • Flags controlling the chooser. Multiple selection is not valid for this call.
Returns:
The result of displaying the chooser.
Available since:
6.25

/
/
/
ShowContentChooser

ShowContentChooser method

Class:  Rhino.Render.Utilities

Nothing found