Description:

Determines whether a double value is valid within the RhinoCommon context. Rhino does not use Double.NaN by convention, so this test evaluates to True if: x is not equal to RhinoMath.UnsetValue System.Double.IsNaN(x) evaluates to false System.Double.IsInfinity(x) evaluates to false

Syntax:
public static bool IsValidDouble(
double x
)
Parameters:
  • x
  • Type: double
  • double number to test for validity.
Returns:
Type: bool
True if the number if valid, False if the number is NaN, Infinity or Unset.
Available since:
5.0

/
/
/
IsValidDouble

IsValidDouble method

Class:  Rhino.RhinoMath

Nothing found