ContentUI class
This class represents the user interface (UI) of a content. A content's UI appears inside an editor which is represented by IRhRdkContentEditor.The UI is the part of the editor which allows the user to view and modify the persistent state of the selected content(s). This interface is implemented by RDK internally in the core content class, CRhRdkCoreContent. If you do not override CRhRdkCoreContent::CreateUI() you do not have to concern yourself with the details.If however, you do want to override CreateUI() to create your own custom UI, then you must derive your UI class from CRhRdkCustomContentUI and implement this interface to support your own UI design. \note CRhRdkCustomContentUI implements some of this interface for you.
Derived Classes: ExpandableContentUI
Namespace: Rhino.UI.Controls
ContentUI: references