CheckNewObjects

Enables or disables new object error reporting that occurs when they are created or imported. For more information, see the Rhino help file for the CheckNewObjects command.

Syntax

Rhino.CheckNewObjects ([blnCheck])

Parameters

blnCheck

Optional.  Number.  Enables (True) or disables (False) new object error reporting.

Returns

Boolean

If blnCheck is not specified, then the current reporting mode if successful.

Boolean

If blnCheck is specified, then the previous reporting mode if successful.

Null

If not successful, or on error.

Example

Dim blnCheck

blnCheck = Rhino.CheckNewObjects(False)

Call DoImportMessyGeometryFiles

Rhino.CheckNewObjects = blnCheck