DisplayOleAlerts

Enables or disables OLE Server Busy/Not Responding dialog boxes from appearing during a lengthy OLE, or COM, operations. In detail, this function does the following:

Note, the display of OLE Server Busy/Not Responding dialog boxes will be re-enabled whenever the script engine is reset, either by running the ResetRhinoScript command or by having the Reinitialize option enabled in Tools->Options->RhinoScript.

Syntax

Rhino.DisplayOleAlerts (blnDisplay)

Parameters

blnDisplay

Required.  Boolean.  Enable or disable the display of OLE alert dialog boxes.

Returns

Null

If successful or on error.

Example

Dim objExcel

Rhino.DisplayOleAlerts False

On Error Resume Next

Set objExcel = CreateObject("Excel.Application")

...

Also See

Reinitializing RhinoScript

Scripting Options