Osnap

Enables or disables Rhino's object snap modeling aid.  Object snaps are tools for specifying points on existing objects.

Syntax

Rhino.Osnap ([blnEnable])

Parameters

blnEnable

Optional.  Boolean.  The new enabled status, either True or False.

Returns

Boolean

If blnEnable is not specified, then the current object snap status if successful.

Boolean

If blnEnable is specified, then the previous object snap status if successful.

Example

If Not Rhino.Osnap Then

Rhino.Osnap True

End If

Also See

Ortho

OsnapMode

Planar

Snap