IsCurveRational

Verifies an object is a rational NURBS curve object.

Syntax

Rhino.IsCurveRational (strObject [, intIndex])

Parameters

strObject

Required.  String.  The object's identifier.

intIndex

Optional. Number. If strObject identifies a polycurve object, then intIndex identifies the curve segment of the polycurve to query.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a curve")

If Rhino.IsCurve(strObject) Then

If Rhino.IsCurveRational(strObject) Then

Rhino.Print "The object is a rational NURBS curve."

Else

Rhino.Print "The object is not a rational NURBS curve."

End If

Else

Rhino.Print "The object is not a curve."

End If

Also See

IsCurve

IsCurveClosed

IsCurveLinear

IsCurvePeriodic