Returns or sets the render mesh maximum aspect ratio property of the active document.
For more information on render meshes, see the Document Properties: Mesh topic in the Rhino help file.
Rhino.RenderMeshMaxAspectRatio ([dblRatio])
dblRatio |
Optional. Number. The render mesh maximum aspect ratio. The suggested range, when not zero, is from 1 to 100. |
Number |
If dblRatio is not specified, the current render mesh maximum aspect ratio if successful. |
Number |
If dblRatio is specified, the previous render mesh maximum aspect ratio if successful. |
Null |
If not successful, or on error. |
Rhino.Print "Quality: " & Rhino.RenderMeshQuality
Rhino.Print "Mesh density: " & Rhino.RenderMeshDensity
Rhino.Print "Maximum angle: " & Rhino.RenderMeshMaxAngle
Rhino.Print "Maximum aspect ratio: " & Rhino.RenderMeshMaxAspectRatio
Rhino.Print "Minimun edge length: " & Rhino.RenderMeshMinEdgeLength
Rhino.Print "Maximum edge length: " & Rhino.RenderMeshMaxEdgeLength
Rhino.Print "Maximum distance, edge to surface: " & Rhino.RenderMeshMaxDistEdgeToSrf
Rhino.Print "Minumum initial grid quads: " & Rhino.RenderMeshMinInitialGridQuads
Rhino.Print "Other settings: " & Rhino.RenderMeshSettings