GetLayerUserText

Returns user text that is stored on a layer. For more details on User Text, see the discussion found in the User Data Methods summary.

Syntax

Rhino.GetLayerUserText (strLayer [, strKey])

Parameters

strLayer

Required.  String.  The name or identifier of an existing layer.

strKey

Optional.  String.  The key name.  If omitted or an empty string ("") is specified, all key names for the layer are returned.

Returns

String

If strKey is specified, then the associated value if successful.

Array

If strKey is not specified, then an array of key names if successful.

Null

If not successful, or on error.

Example

Rhino.Print Rhino.GetLayerUserText("First Floor", "Description")

Rhino.Print Rhino.GetLayerUserText("Second Floor", "Description")

Also See

SetLayerUserText