IsLayerCurrent

Verifies that a layer is the current layer.

Syntax

Rhino.IsLayerCurrent (strLayer)

Parameters

strLayer

Required.  String.  The name or identifier of an existing layer.

Returns

True

If successful.

False

If not successful.

Null

On error.

Example

Dim strLayer

strLayer = Rhino.GetString("Layer name")

If Rhino.IsLayer(strLayer) Then

If Rhino.IsLayerCurrent(strLayer) Then

Rhino.Print "The layer is current."

Else

Rhino.Print "The layer is not current."

End If

Else

Rhino.Print "The layer does not exist."

End If

Also See

IsLayer

IsLayerEmpty

IsLayerLocked

IsLayerOn

IsLayerReference

IsLayerSelectable

IsLayerVisible