LayerId

Returns the identifier of a layer given the layer's name.

Syntax

Rhino.LayerId (strLayer)

Parameters

strLayer

Required.  String.  The name of an existing layer.

Returns

String

The layer's identifier if successful.

Null

If not successful, or on error.

Example

Dim arrLayers, strLayer

arrLayers = Rhino.LayerNames

If IsArray(arrLayers) Then

  For Each strLayer In arrLayers

    Rhino.Print Rhino.LayerId(strLayer)

  Next

End If

Also See

LayerName