LayerIds

Returns the identifiers of all layers in the document. Layer identifiers can be used with all layer-related methods.

Syntax

Rhino.LayerIds ()

Parameters

None.

Returns

Array

An array of layer identifiers if successful.

Null

If not successful, or on error.

Example

Dim arrLayers, strLayer

arrLayers = Rhino.LayerIds

If IsArray(arrLayers) Then

  For Each strLayer In arrLayers

    Rhino.Print strLayer

  Next

End If

Also See

LayerCount

LayerNames