SelectedLayers

Returns the identifiers of the layers that are currently selected in Rhino's layer user interface.

Syntax

Rhino.SelectedLayers ()

Parameters

None.

Returns

Array

An array of layer identifiers if successful.

Null

If not successful, or on error.

Example

Dim arrLayers, strId, strLayer

arrLayers = Rhino.SelectedLayers

If IsArray(arrLayers) Then

  For Each strId in arrLayers

    strLayer = Rhino.LayerName(strId)

    Call Rhino.Print(strLayer)

  Next

End If

Also See

LayerName

SelectLayers