Returns the angle whose tangent is the quotient of two specified numbers.
Rhino.ATan2 (dblX, dblY)
dblX |
Required. Number. The y coordinate of a point. |
dblY |
Required. Number. The x coordinate of a point. |
Number |
An angle, θ, measured in radians, such that -PI ≤ θ ≤ PI, and Tan(θ) = y / x, where (x, y) is a point in the Cartesian plane. Observe the following:
The return value is the angle in the Cartesian plane formed by the x-axis, and a vector starting from the origin, (0, 0), and terminating at the point, (x, y). |
||||
Null |
If not successful, or on error. |
MsgBox Rhino.ATan2(2.0, 1.0)