Returns or modifies an object's custom render mesh parameter's maximum aspect ratio property.
For more information on render meshes, see the Document Properties: Mesh topic in the Rhino help file.
Rhino.ObjectMeshMaxAspectRatio (strObject [, dblRatio])
strObject |
Required. Object. The identifier of an object that has custom render mesh parameters. |
dblRatio |
Optional. Number. The render mesh maximum aspect ratio. The suggested range, when not zero, is from 1 to 100. |
Number |
If dblRatio is not specified, the current render mesh maximum aspect ratio if successful. |
Number |
If dblRatio is specified, the previous render mesh maximum aspect ratio if successful. |
Null |
If not successful, or on error. |
Dim strObject
strObject = Rhino.GetObject("Select object")
If Rhino.ObjectHasMesh(strObject) = True Then
Rhino.Print "Quality: " & Rhino.ObjectMeshQuality
Rhino.Print "Mesh density: " & Rhino.ObjectMeshDensity
Rhino.Print "Maximum angle: " & Rhino.ObjectMeshMaxAngle
Rhino.Print "Maximum aspect ratio: " & Rhino.ObjectMeshMaxAspectRatio
Rhino.Print "Minimun edge length: " & Rhino.ObjectMeshMinEdgeLength
Rhino.Print "Maximum edge length: " & Rhino.ObjectMeshMaxEdgeLength
Rhino.Print "Maximum distance, edge to surface: " & Rhino.ObjectMeshMaxDistEdgeToSrf
Rhino.Print "Minumum initial grid quads: " & Rhino.ObjectMeshMinInitialGridQuads
Rhino.Print "Other settings: " & Rhino.ObjectMeshSettings
End If