GetPlugInObject

Returns an automation (COM) object from a specified plug-in. Note, not all plug-ins contain scriptable objects. Check with the manufacturer of your plug-in to see if they support this capability.

Syntax

GetPlugInObject (strPlugIn, strInterface)

Parameters

strPlugIn

Required.  String.  The id of a registered plug-in that supports scripting.  If the plug-in is registered but not loaded, it will be loaded.

strInterface

Required.  String.  The id of interface, or object type, to retrieve.

Returns

Object

An automation (COM) object if successful.

Null

If not successful, or on error.

Example

Dim objRhino, objPlugIn, strPlugIn, strInterface

strPlugIn = "1C7A3523-9A8F-4cec-A8E0-310F580536A7"

strInterface = "00020400-0000-0000-C000-000000000046"

On Error Resume Next

Set objRhino = CreateObject("Rhino.Application")

If Err.Number == 0 Then

  objPlugIn.GetPlugInObject(strPlugIn, strInterface)

End If