Returns the identifiers of objects based on the objects' material source. An object's material source can be obtained using ObjectMaterialSource.
Rhino.ObjectsByMaterialSource (intMaterialSource [, blnSelect [, intType]])
intMaterialSource |
Required. Number. The material source to query, where:
|
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
blnSelect |
Optional. Boolean. Select the objects. If omitted, the objects are not selected (False). |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
intType |
Optional. Number. The type(s) of geometry objects (points, curves, surfaces, meshes, etc.) that can be returned. Object types can be added together to filter several different kinds of geometry.
|
Array |
An array of strings identifying the objects if successful. |
Null |
If not successful, or on error. |
Dim arrObjects
arrObjects = Rhino.ObjectsByMaterialSource(1, True)