VisibleObjects

Returns the identifiers of all objects that are visible in a specified view.

Syntax

Rhino.VisibleObjects ([strView [, blnSelect [, blnIncludeLights [, blnIncludeGrips]]]])

Parameters

strView

Optional.  String.  The title of the view.  If omitted, the current active view is used.

blnSelect

Optional.  Boolean.  Select the objects.  If omitted, the object is not selected (False).

blnIncludeLights

Optional.  Boolean.  Include light objects.  If omitted, light objects are not returned (False).

blnIncludeGrips

Optional.  Boolean.  Include grips objects.  If omitted, grips objects are not returned (False).

Returns

Array

An array of strings identifying the objects if successful.

Null

If not successful, or on error.

Example

Dim arrObjects, strObject

arrObjects = Rhino.VisibleObjects("Top")

If IsArray(arrObjects) Then

For Each strObject In arrObjects

Rhino.Print "Object identifier: " & strObject

Next

End If

Also See

IsView

IsVisibleInView