WindowPick

Picks objects using either a window or crossing selection.

Syntax

Rhino.WindowPick (arrCorner1, arrCorner2 [, strView [, blnSelect [, blnWindow]]])

Parameters

arrCorner1

Required.  Array. The first 3-D corner point of the selection rectangle.

arrCorner2

Required.  Array. The second 3-D corner point of the selection rectangle.

strView

Optional.  String.  The title or identifier of the view.  If omitted, the current active view is used.

blnSelect

Optional.  Boolean.  Select picked objects.  If omitted, picked objects are not selected (False).

blnWindow

Optional.  Boolean. If True (Default), then a window selection is performed.  If False, then a crossing selection is performed.

Returns

Array

An array of strings identifying the objects if successful.

Null

If not successful, or on error.

Example

Rhino.WindowPick Array(0,0,0), Array(10,10,0), , True

Also See

PointPick