ConvertSurfaceToBezier

Changes the structure of a NURBS surface to a Bézier surface.

Syntax

Rhino.ConvertSurfaceToBezier (strObject [, blnDelete])

Parameters

strObject

Required.  String.  The object's identifier.

blnDelete

Optional.  Boolean.  Delete the original object.  The default is to not delete the original object (False).

Returns

Array

An array of strings identifying the newly created surface objects if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a surface to convert to Beziers")

If Rhino.IsSurface(strObject) Then

Call Rhino.ConvertSurfaceToBezier(strObject, true)

End If

Also See

IsSurface