CreateSolid

Creates a closed polysurface from surfaces and polysurfaces that bound a region in space.

Syntax

Rhino.CreateSolid (arrObjects [,blnDelete])

Parameters

arrObjects

Required.  Array.  An array of strings identifying two or more surfaces or polysurfaces objects from which to create the solid.

blnDelete

Optional.  Boolean.  Delete input objects.  The default is not to delete objects (False).

Returns

Array

The identifiers of one or more newly created closed polysurface object if successful.

Null

If not successful, or on error.

Example

Dim arrObjects

arrObjects = Rhino.GetObjects("Select surfaces and polysurfaces", 24)

If UBound(arrObjects) > 0 Then

Rhino.CreateSolid arrObjects, True

End If

Also See

JoinSurfaces