ExtendSurface

Lengthens an untrimmed surface object by a factor value.

Syntax

Rhino.ExtendSurface (strObject, arrParameter, dblLength, blnSmooth)

Parameters

Parameters

strObject

Required.  String.  The object's identifier.

arrParameter

Required.  Array.  An array containing the U,V parameter of the surface to evaluate. The surface edge that is closest to the U,V parameter will be the edge that is extended.

dblLength

Required.  Number.  The amount to extend the surface.

blnSmooth

Optional.  Boolean.  If True (Default), the surface is extended smoothly curving from the edge. If False, the surface is extended in a straight line from the edge.

Returns

Boolean

True or False indicating success or failure.

Null

On error.

Example

Const rhSurface = 8

Dim arrParameter

arrPick = Rhino.GetObjectEx("Select surface to extend", rhSurface)

If IsArray(arrPick) Then

  arrParameter = Rhino.SurfaceClosestPoint(arrPick(0), arrPick(3))

  Call Rhino.ExtendSurface(arrPick(0), arrParameter, 5.0)

End If

Also See

IsSurface