ExtrudeCurveNormal

Extrudes a curve, that lies on a surface, normal to the surface. This is functionally similar to the Fin command.

Syntax

Rhino.ExtrudeCurveNormal (strSurface, strCurve, dblDistance)

Parameters

strSurface

Required.  String.  The identifier of the base surface object.

strCurve

Required.  String.  The identifier of the curve, that lies on the surface, to extrude.

dblDistance

Required.  Number.  The distance to extrude.

Returns

String

The identifier of the new surface object if successful.

Null

If not successful, or on error.

Example

Dim strSurface, strCurve

strCurve = Rhino.GetObject("Select curve to extrude normal to surface", 4)

strSurface = Rhino.GetObject("Select base surface", 8)

Rhino.ExtrudeCurveNormal strSurface, strCurve, 5.0

Also See

ExtrudeCurvePoint

ExtrudeCurveStraight

ExtrudeCurveTapered

ExtrudeSurface