IntersectBreps

Intersects a surface or polysurface object with another surface or polysurface object. Note, unlike the SurfaceSurfaceIntersection function this function works on trimmed surfaces.

Syntax

Rhino.IntersectBreps (strObject1, strObject2 [, dblTolerance [, blnReturnBoolean]])

Parameters

strObject1

Required.  String.  The first surface or polysurface object's identifier.

strObject2

Required.  String.  The second surface or polysurface object's identifier.

dblTolerance

Optional.  Number.  The intersection tolerance.  If omitted, the document's absolute tolerance is used.

blnReturnBoolean

Optional.  Boolean.  Returns a Boolean value, either True or False, indicating whether or not the two objects intersected. In this case, no geometry is created and added to the document. The default value is False, which means that if the two objects intersect, the function will create the intersection geometry and return their object identifiers.

Returns

Array

If blnReturnBoolean is omitted or False, then an array of strings identifying the newly created intersection curve and point objects if successful.

Boolean

If blnReturnBoolean is specified and True, then True or False indicating whether or not the two objects intersected if successful.

Null

If not successful, or on error.

Example

Dim strBrep1, strBrep2

strBrep1 = Rhino.GetObject("Select the first surface or polysurface", 24)

If Not IsNull(strBrep1) Then

strBrep2 = Rhino.GetObject("Select the second surface or polysurface", 24)

If Not IsNull(strBrep2) Then

Rhino.IntersectBreps strBrep1, strBrep2

End If

End If

Also See

SurfaceSurfaceIntersection