IsCone

Determines if a surface is a portion of a cone.

Syntax

Rhino.IsCone (strSurface [, blnTolerance])

Rhino.IsCone (strSurface [, dblTolerance])

Parameters

strSurface

Required.  String.  The surface object's identifier.

blnTolerance

Optional.  Boolean.  If False (Default), then the document's absolute tolerance is used when checking. If True, then Rhino's internal zero tolerance is used when checking.

dblTolerance

Optional.  Number.  The tolerance to use when checking. If omitted, the document's absolute tolerance is used.

Returns

Boolean

True if successful, otherwise False.

Null

On error.

Example

Dim strSurface

strSurface = Rhino.GetObject("Select a surface", 8)

If Not IsNull(strSurface) Then

  If Rhino.IsCone(strSurface) Then

    Rhino.Print "The surface is a portion of a cone."

  Else

    Rhino.Print "The surface is not a portion of a cone."

  End If

End If

Also See

IsCylinder

IsSphere

IsSurface

IsTorus