SurfaceCount

Returns the number of surfaces, or faces, in a polysurface.

Syntax

Rhino.SurfaceCount (strObject)

Parameters

Parameters

strObject

Required.  String.  The polysurface object's identifier.

Returns

Number

The number of surfaces, or faces, in a polysurface if successful.

Null

If not successful, or on error.

Example

Const rhPolysrf = 16

Dim strObject

strObject = Rhino.GetObject("Select polysurface", rhPolysrf, true)

If Not IsNull(strObject) Then

  MsgBox "Face count = " & CStr(Rhino.SurfaceCount(strObject))

End If

Also See

BrepClosestPoint

ExtractSurface

IsSurface

IsPolysurface